Plesk upgrade is not starting: Couldn't resolve host autoinstall.plesk.com

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux
  • Plesk 12.5 for Windows

Created:

2016-11-16 13:12:08 UTC

Modified:

2016-12-21 20:10:47 UTC

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Plesk upgrade is not starting: Couldn't resolve host autoinstall.plesk.com

Symptoms

Plesk upgrade fails with error:

    File downloading products.inf3: Error: Couldn't resolve host 'autoinstall.plesk.com', retry...
Error: Couldn't resolve host 'autoinstall.plesk.com', retry...

Cause

autoinstall.plesk.com is not resolvable from the Plesk server.

Resolution

Do the following tests to confirm if there is any network connectivity issue with http://autoinstall.plesk.com

  1. Ping:

    # ping autoinstall.plesk.com
  2. DNS resolution:

    nslookup autoinstall.plesk.com
  3. Access the http://autoinstall.plesk.com URL from web browser, and check if it is showing Plesk packages correctly.

    For Linux systems only:

  4. Make sure that name servers are correct in /etc/resolv.conf :

    root@test# cat /etc/resolv.conf
    nameserver 8.8.8.8
  5. Check that there is no search record in the /etc/resolv.conf file. If the search record is present, then it prevents DHCP client from updating /etc/resolv.conf file (if it is updated automatically). Either comment out search directive, or add link to the autoinstall.plesk.com host as the following:

    # cat /etc/resolv.conf
    ; generated by /sbin/dhclient-script
    search example.com autoinstall.plesk.com
    nameserver 192.168.0.1
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