RKHunter warnings: command has been replaced by a script

Created:

2016-11-16 13:12:03 UTC

Modified:

2017-04-24 11:15:38 UTC

0

Was this article helpful?


Have more questions?

Submit a request

RKHunter warnings: command has been replaced by a script

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Symptoms

Security check through Plesk at Modules > Watchdog > Security > Start finishes successfully, however, the following warnings are reported in /var/log/rkhunter.log :

Warning: The command '/usr/bin/GET' has been replaced by a script: /usr/bin/GET: perl script text executable
Warning: The command '/usr/bin/groups' has been replaced by a script: /usr/bin/groups: Bourne shell script text executable
Warning: The command '/usr/bin/ldd' has been replaced by a script: /usr/bin/ldd: Bourne shell script text executable
Warning: The command '/sbin/ifdown' has been replaced by a script: /sbin/ifdown: Bourne-Again shell script text executable
Warning: The command '/sbin/ifup' has been replaced by a script: /sbin/ifup: Bourne-Again shell script text executable

These files exist in the system.

Resolution

Add the following directives to the RKHunter configuration file ("ATTENTION!" section can be ignored):

/usr/local/psa/etc/modules/watchdog/rkhunter.conf
--->8---
SCRIPTWHITELIST=/usr/bin/GET
SCRIPTWHITELIST=/usr/bin/groups
SCRIPTWHITELIST=/usr/bin/ldd
SCRIPTWHITELIST=/sbin/ifdown
SCRIPTWHITELIST=/sbin/ifup
---8<---
Have more questions? Submit a request

2 Comments

  • 0
    Avatar
    TurnKeyWebsites

    At the top of file /usr/local/psa/etc/modules/watchdog/rkhunter.conf there is a warning to not modify

    #DO NOT MODIFY THIS FILE BECAUSE IT WAS GENERATED AUTOMATICALLY,
    #SO ALL YOUR CHANGES WILL BE LOST AFTER YOU UPGRADE PARALLELS PLESK PANEL.

     

     

  • 0
    Avatar
    Lev Iurev

    Hi @TurnKeyWebsites this warning could be ignored

Please sign in to leave a comment.