Plesk installer failing with 403 Forbidden file type or location

Refers to:

  • Plesk for Linux

Created:

2016-11-16 13:11:32 UTC

Modified:

2016-12-21 20:09:20 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk installer failing with 403 Forbidden file type or location

Symptoms

When installing any packages using autoinstaller , it is failing with the following error:

    WARNING: The following packages cannot be authenticated!
psa-migration-manager psa-migration-agents
Authentication warning overridden.
Err http://autoinstall.plesk.com/ubuntu/PSA_12.0.18/ trusty/all psa-migration-manager amd64 12.0.18-ubuntu14.04.build1200140610.21
403 Forbidden file type or location: http://autoinstall.plesk.com/ubuntu/PSA_12.0.18/../../PSA_12.0.18/dist-deb-Ubuntu-14.04-x86_64/opt/migration/psa-migration-manager_12.0.18-ubuntu14.04.build1200140610.21_amd64.deb
Err http://autoinstall.plesk.com/ubuntu/PSA_12.0.18/ trusty/all psa-migration-agents amd64 12.0.18-ubuntu14.04.build1200140610.21
403 Forbidden file type or location: http://autoinstall.plesk.com/ubuntu/PSA_12.0.18/../../PSA_12.0.18/dist-deb-Ubuntu-14.04-x86_64/opt/migration/psa-migration-agents_12.0.18-ubuntu14.04.build1200140610.21_amd64.deb
E: Failed to fetch http://autoinstall.plesk.com/ubuntu/PSA_12.0.18/../../PSA_12.0.18/dist-deb-Ubuntu-14.04-x86_64/opt/migration/psa-migration-manager_12.0.18-ubuntu14.04.build1200140610.21_amd64.deb 403 Forbidden file type or location: http://autoinstall.plesk.com/ubuntu/PSA_12.0.18/../../PSA_12.0.18/dist-deb-Ubuntu-14.04-x86_64/opt/migration/psa-migration-manager_12.0.18-ubuntu14.04.build1200140610.21_amd64.deb

E: Failed to fetch http://autoinstall.plesk.com/ubuntu/PSA_12.0.18/../../PSA_12.0.18/dist-deb-Ubuntu-14.04-x86_64/opt/migration/psa-migration-agents_12.0.18-ubuntu14.04.build1200140610.21_amd64.deb 403 Forbidden file type or location: http://autoinstall.plesk.com/ubuntu/PSA_12.0.18/../../PSA_12.0.18/dist-deb-Ubuntu-14.04-x86_64/opt/migration/psa-migration-agents_12.0.18-ubuntu14.04.build1200140610.21_amd64.deb

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

ERROR: An error occurred on attempt to install packages.
Attention! Your software might be inoperable.
Please, contact product technical support.

Cause

Misconfigured proxy server used by apt

Resolution

  1. Check the configuration file which contains proxy settings

    :# grep -ir Proxy /etc/apt/

    ./apt.conf:Acquire::http::Proxy "http://ubuntu.mirror.netdiscounter.net:9999";
  2. Remove the Proxy lines from the configuration and rerun autoinstaller.

Have more questions? Submit a request
Please sign in to leave a comment.