After creating a new subscription DNS records are not visible.

Refers to:

  • Plesk

Created:

2016-11-16 13:11:01 UTC

Modified:

2016-12-21 20:08:12 UTC

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After creating a new subscription DNS records are not visible.

Symptoms

After creating a new subscription in Plesk DNS records are not visible. Restore data from DNS records template not helped.

mysql> select id from psa.dns_recs where id=0;
+----+
| id |
+----+
| 0 |
+----+
1 row in set (0.01 sec)

Cause

The problem caused by corrupted record in the ' psa.dns_recs ' table, by unknown reason the table has record with id=0 . Plesk is using id=0 in UPDATE statemenet to insert data into autoincrement field, usually the table do not have an autoincrement field with id=0 . As a result, all data written by MySQL into this record.

Resolution

Delete invalid record from the table:

mysql> delete from psa.dns_recs where id=0;
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