It is not possible to login to Plesk Panel from the container's Power Panel.

Created:

2016-11-16 13:10:11 UTC

Modified:

2017-08-16 18:24:37 UTC

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It is not possible to login to Plesk Panel from the container's Power Panel.

Applicable to:

  • Plesk for Windows

Symptoms

It is not possible to login to Plesk Panel from the container's Power Panel.

When you try to log in, you are redirected to an URL with the container's short hostname, which is not resolved and you are faced with Server not found error message.

Cause

The container's hostname is incorrectly validated because of the network/firewall configuration in the container.

Resolution

When you click the Log In to Plesk button

logintoplesk

the login is performed according to the XSL transform rules defined in the C:\\Program Files (x86)\\Parallels\\Parallels Virtual Automation\\Power Panel\\xsl\\screens\\panel\\plesk\\login.xsl file on the node.

The hostname/address that should be used is defined by host-sel variable:

<!-- host -->
<xsl:variable name="host-sel">
<xsl:choose>
<xsl:when test="$platform-is-linux">
<xsl:value-of select="$service-status/ip-address"/>
</xsl:when>
<xsl:otherwise>
<xsl:variable name="host"
select="concat($vconfig/hostname,
sw:if(string($vconfig/search_domain[1])='', '',
concat('.', $vconfig/search_domain[1])))"/>
<xsl:variable name="host-ip" select="$service-status/ip-address"/>
<xsl:value-of select="sw:validate-location($host,$host-ip)"/>
</xsl:otherwise>
</xsl:choose>
</xsl:variable>
<xsl:variable name="h" select="sw:if(contains($host-sel, ':'), concat('[', $host-sel, ']'), $host-sel)" />

<!-- location -->
<xsl:variable name="location" select="concat('https://',$h,':',$psa-uri/port,$psa-uri/url,'?LoginTicket=',$new-ticket,'&amp;psa_active_lang=',$plesk-lang-id,'&amp;psa_active_skin=',$plesk-skin-id,
'&amp;java_mode=', sw:sesget('java_mode'), '&amp;js_mode=', sw:sesget('js_mode'))"/>

If the container's short hostname can be pinged from the node:

C:\\Users\\Administrator>vzlist 1000

VEID NPROC STATUS IP_ADDR HOSTNAME
1000 31 running 10.10.10.12 CT1000

C:\\Users\\Administrator>ping CT1000

Pinging CT1000 [fe80::7c42:49ae:23ff:6efc%15] with 32 bytes of data:
Reply from fe80::7c42:49ae:23ff:6efc%15: time<1ms
Reply from fe80::7c42:49ae:23ff:6efc%15: time<1ms
Reply from fe80::7c42:49ae:23ff:6efc%15: time<1ms

Ping statistics for fe80::7c42:49ae:23ff:6efc%15:
Packets: Sent = 3, Received = 3, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

The short hostname will be considered valid, and Plesk Panel login will be redirected to https://CT1000:8443 resulting in the failed hostname resolution from the client's side.

The problem can be fixed either of the following ways:

  1. Enable firewall inside the container (if it is already enabled, make sure to create a rule to block incoming connections to the port 5355 in the container).
  2. Stop the "DNS Client" service inside the container.
  3. Disable IPv6 Protocol inside the container (if there is no public IPv6 address assigned to the container).
  4. Add the correct search domain to the container's configuration file. For example, if the FQDN name of the container is CT1000.testdomain.com - execute the following command from the node:
    vzctl set 1000 --save --searchdomain testdomain.com

Solutions 1, 2, and 3 will result in redirection to Plesk Panel using the container's IP address: https://10.10.10.12:8443 .

Solution 4 will result in redirection to Plesk Panel using the container's FQDN: https://CT1000.testdomain.com:8443 .

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