Unable to send email: Could not open secure TLS connection to the server

Created:

2016-11-16 13:10:05 UTC

Modified:

2017-08-08 13:15:53 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to send email: Could not open secure TLS connection to the server

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux

Symptoms

  • Unable to send an email from webmail(Horde/RoundCube), the following error appears:

    Could not open secure TLS connection to the server
  • The following errors can be observed in /var/log/psa-horde/psa-horde.log :

    2016-05-25T08:15:04+00:00 DEBUG: HORDE Load config file (conf.php; app: horde) [pid 51301 on line 109 of "/usr/share/psa-pear/pear/php/Horde/Registry/Loadconfig.php"]
    2016-05-25T08:15:04+00:00 DEBUG: HORDE [imp] Load config file (conf.php; app: imp) [pid 51301 on line 109 of "/usr/share/psa-pear/pear/php/Horde/Registry/Loadconfig.php"]
    2016-05-25T08:15:04+00:00 ERR: HORDE [imp] Could not open secure TLS connection to the server. [pid 51301 on line 1157 of "/usr/share/psa-horde/imp/lib/Compose.php"]
    2016-05-25T08:15:04+00:00 DEBUG: HORDE 1. Horde_Core_Ajax_Application->doAction() /usr/share/psa-horde/services/ajax.php:61
    2. call_user_func() /usr/share/psa-pear/pear/php/Horde/Core/Ajax/Application.php:175
    3. IMP_Ajax_Application_Handler_Common->sendMessage()
    4. IMP_Compose->buildAndSendMessage() /usr/share/psa-horde/imp/lib/Ajax/Application/Handler/Common.php:555
  • The following errors appear in /var/log/maillog :

    May 25 10:27:05 server postfix/smtpd[52260]: SSL_accept error from server.example.com[127.0.0.1]: -1
    May 25 10:27:05 server postfix/smtpd[52260]: warning: TLS library problem: error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol:s23_srvr.c:647:
    May 25 10:27:05 server postfix/smtpd[52260]: lost connection after STARTTLS from server.example.com[127.0.0.1]

Cause

Incorrect settings in /etc/psa-webmail/horde/horde/conf.php .

Resolution

Correct settings in /etc/psa-webmail/horde/horde/conf.php like it is shown below:

// send email with authorization on SMTP server
$conf['mailer']['params']['host'] = 'localhost';
$conf['mailer']['params']['port'] = 25;
$conf['mailer']['params']['auth'] = true;
$conf['mailer']['type'] = 'smtp';
Have more questions? Submit a request
Please sign in to leave a comment.