Roundcube filter does not work: Could not connect to Sieve server

Created:

2016-11-16 13:09:56 UTC

Modified:

2017-08-16 18:24:47 UTC

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Roundcube filter does not work: Could not connect to Sieve server

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux
  • Plesk 11.x for Linux
  • Plesk 12.0 for Linux

Symptoms

1. The following error appears when attempting to open Settings > Filter in Roundcube webmail:

    Could not connect to Sieve server

Could not connect to Sieve server

2. The var/log/plesk-roundcube/errors log file shows the following:

ERROR: Connection refused (111)

ERROR: Not currently connected (1)

Cause

1. Sieve filter is not supported in Plesk 11.5 or older versions. In Plesk 12, Sieve support is provided with Dovecot. A feature request with ID RT #1827961 has been created for the Plesk Service Team and will be considered for inclusion in a future product version.

2. Dovecot's plugin managesieve is not listening to the port.

Resolution

For Plesk 12:

Switch from Courier IMAP to Dovecot using Plesk autoinstaller: Home > Tools & Settings > Updates & Upgrades > Add\Remove components > Mail > Dovecot .

More about Dovecot is available in developers blog .

More information is available on forums .

Please also see Plesk 12 Release notes .

For Plesk 12.5 and higher:

  • By default, Dovecot's plugin managesieve , which is used for managing sieve, is listening to port 4190. Check whether this port is listened:

    netstat -tulpn | grep dovecot
    
    tcp        0      0 0.0.0.0:993             0.0.0.0:*               LISTEN      19933/dovecot
    
    tcp        0      0 0.0.0.0:995             0.0.0.0:*               LISTEN      19933/dovecot
    
    tcp        0      0 0.0.0.0:110             0.0.0.0:*               LISTEN      19933/dovecot
    
    tcp        0      0 0.0.0.0:143             0.0.0.0:*               LISTEN      19933/dovecot
    
    tcp6       0      0 :::993                  :::*                    LISTEN      19933/dovecot
    
    tcp6       0      0 :::995                  :::*                    LISTEN      19933/dovecot
    
    tcp6       0      0 :::110                  :::*                    LISTEN      19933/dovecot
    
    tcp6       0      0 :::143                  :::*                    LISTEN      19933/dovecot
    
  • Check the /etc/dovecot/conf.d/90-plesk-sieve.conf file. It should contain the following line:

    protocols = $protocols sieve
    
  • Check that there are no additional /etc/dovecot/conf.d/*.conf files with similar lines. If there are, check that they have sieve listed in protocols.

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