Cannot backup a domain if customer's email contains IDN domain name

Created:

2016-11-16 13:09:30 UTC

Modified:

2017-08-16 18:30:28 UTC

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Cannot backup a domain if customer's email contains IDN domain name

Applicable to:

  • Plesk 11.x for Windows

Symptoms

Here are steps to reproduce the issue:

  • Create a customer with IDN name in email, e.g. “ email@просто-сайт.рф
  • Create a subscription for this customer, “ просто-сайт.рф
  • Backup the subscription
  • Check backup results:
    Warning:        domain "просто-сайт.рф"
    Cannot dump dns zone with id '12'[Email value 'email@просто-сайт.рф' is not valid]

Cause

Such behavior is considered to be a software issue. The fix will be included in future Parallels Plesk Panel updates released after 11.5. You can track it using the following ID:

PPPM-536 - Cannot dump dns zone while creating a backup if e-mail contains Russian international symbols

Workaround

Change customers email with non-russian domain name (with customer's confirmation only):

Home > Customers > %customer% > Edit Contact Info

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