Unable to send an email: SASL PLAIN authentication failed: no mechanism available

Refers to:

  • Plesk Onyx for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:09:22 UTC

Modified:

2016-12-21 20:04:38 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to send an email: SASL PLAIN authentication failed: no mechanism available

Symptoms

Unable to send an email.

The following warnings can be found in /var/log/maillog :

Dec 28 05:34:19 94 postfix/smtpd[25318]: warning: unknown[xxx.xxx.xxx.xxx]: SASL PLAIN authentication failed: no mechanism available
Dec 28 05:34:19 94 postfix/smtpd[25318]: warning: unknown[xxx.xxx.xxx.xxx]: SASL LOGIN authentication failed: no mechanism available

Debian 6 is used, but libsasl2-2 , libsasl2-modules packages are installed for Debian 7:

# dpkg -l | grep sasl
ii libauthen-sasl-perl 2.1500-1 all Authen::SASL - SASL Authentication framework
ii libsasl2-2:amd64 2.1.25.dfsg1-6+deb7u1 amd64 Cyrus SASL - authentication abstraction library
ii libsasl2-modules:amd64 2.1.25.dfsg1-6+deb7u1 amd64 Cyrus SASL - pluggable authentication modules
ii libsasl2-modules-sqlite3 1.0.1-11080119 amd64 sqlite3 plugin for Cyrus SASL
ii sasl2-bin 2.1.23.dfsg1-7 amd64 Cyrus SASL - administration programs for SASL users database

Cause

Packages from another operating system are installed.

Resolution

  1. Move all 3rd party repositories to another directory and reinstall libsasl2-2 , libsasl2-modules packages:

    # mv /etc/apt/sources.list.d/* /root/sourceslist
    # dpkg --purge --force-depends libsasl2-modules libsasl2-2
    # apt-get install libsasl2-modules libsasl2-2
  2. Check SMTP authorization does not work with Postfix MTA .

Have more questions? Submit a request
Please sign in to leave a comment.