MySQL upgrade fails: Error: Package: php-mysql-5.4.45-5.el6.remi.x86_64 (@remi)

Created:

2016-11-16 13:09:21 UTC

Modified:

2017-08-08 13:14:34 UTC

2

Was this article helpful?


Have more questions?

Submit a request

MySQL upgrade fails: Error: Package: php-mysql-5.4.45-5.el6.remi.x86_64 (@remi)

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

Unable to upgrade MySQL to 5.6 version:

    # yum install mysql
Loaded plugins: fastestmirror, priorities
Setting up Install Process
Loading mirror speeds from cached hostfile
* base: mirror.atlanticmetro.net
* epel: mirror.cogentco.com
* extras: mirror.vtti.vt.edu
* remi: mirrors.mediatemple.net
* updates: mirror.atlanticmetro.net
Package mysql is obsoleted by mysql-community-client, trying to install mysql-community-client-5.6.29-2.el6.x86_64 instead
Resolving Dependencies
--> Running transaction check
---> Package mysql.x86_64 0:5.5.48-1.el6.remi will be obsoleted
--> Processing Dependency: real-mysql(x86-64) = 5.5.48-1.el6.remi for package: mysql-server-5.5.48-1.el6.remi.x86_64
---> Package mysql-community-client.x86_64 0:5.6.29-2.el6 will be obsoleting
--> Processing Dependency: mysql-community-libs(x86-64) = 5.6.29-2.el6 for package: mysql-community-client-5.6.29-2.el6.x86_64
--> Running transaction check
---> Package mysql-community-libs.x86_64 0:5.6.29-2.el6 will be obsoleting
--> Processing Dependency: mysql-community-common(x86-64) = 5.6.29-2.el6 for package: mysql-community-libs-5.6.29-2.el6.x86_64
---> Package mysql-community-server.x86_64 0:5.6.29-2.el6 will be obsoleting
--> Processing Dependency: libnuma.so.1(libnuma_1.2)(64bit) for package: mysql-community-server-5.6.29-2.el6.x86_64
--> Processing Dependency: libnuma.so.1(libnuma_1.1)(64bit) for package: mysql-community-server-5.6.29-2.el6.x86_64
--> Processing Dependency: libnuma.so.1()(64bit) for package: mysql-community-server-5.6.29-2.el6.x86_64
---> Package mysql-libs.x86_64 0:5.5.48-1.el6.remi will be obsoleted
--> Processing Dependency: libmysqlclient.so.18(libmysqlclient_16)(64bit) for package: php-mysql-5.4.45-5.el6.remi.x86_64
---> Package mysql-server.x86_64 0:5.5.48-1.el6.remi will be obsoleted
--> Running transaction check
---> Package mysql-community-common.x86_64 0:5.6.29-2.el6 will be installed
---> Package mysql-libs.x86_64 0:5.5.48-1.el6.remi will be obsoleted
--> Processing Dependency: libmysqlclient.so.18(libmysqlclient_16)(64bit) for package: php-mysql-5.4.45-5.el6.remi.x86_64
---> Package numactl.x86_64 0:2.0.9-2.el6 will be installed
--> Finished Dependency Resolution
Error: Package: php-mysql-5.4.45-5.el6.remi.x86_64 (@remi)
Requires: libmysqlclient.so.18(libmysqlclient_16)(64bit)
Removing: mysql-libs-5.5.48-1.el6.remi.x86_64 (@remi)
libmysqlclient.so.18(libmysqlclient_16)(64bit)
Obsoleted By: mysql-community-libs-5.6.29-2.el6.x86_64 (mysql56-community)
Not found
Available: mysql-libs-5.5.47-1.el6.remi.x86_64 (remi)
libmysqlclient.so.18(libmysqlclient_16)(64bit)
Available: mysql-libs-5.1.73-5.el6_6.i686 (base)
Not found
Available: mysql-libs-5.1.73-5.el6_7.1.i686 (updates)
Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Cause

php-mysql-5.4.45-5.el6.remi.x86_64 is not compatible with mysql-community-libs-5.6.29 .

Resolution

Remove php-mysql-5.4.45-5.el6.remi.x86_64 package:

rpm -e --nodeps php-mysql-5.4.45-5.el6.remi.x86_64
Have more questions? Submit a request
Please sign in to leave a comment.