The following error appears when access the website: PHP Warning: require_once failed to open stream: Permission denied

Refers to:

  • Plesk

Created:

2016-11-16 13:09:04 UTC

Modified:

2016-12-21 20:03:57 UTC

0

Was this article helpful?


Have more questions?

Submit a request

The following error appears when access the website: PHP Warning: require_once failed to open stream: Permission denied

Symptoms

The following error appears when access the website which is not installed from Plesk APS catalog:

PHP Warning:  require_once(C:\\Inetpub\\vhosts\\example.com\\httpdocs): failed to open stream: Permission denied in C:\\Inetpub\\vhosts\\example.com\\httpdocs\\index.php on line 48
PHP Fatal error: require_once(): Failed opening required '' (include_path='.;.\\includes;.\\pear') in C:\\Inetpub\\vhosts\\example.com\\httpdocs\\index.php on line 48

Test file test.php with content:

<?php phpinfo(); ?>

is placed in domain vhost directory C:\\Inetpub\\vhosts\\example.com\\httpdocs\ est.php and shows php inofrmation by address: http://example.com/test.php .

Cause

Website is running thirdparty cms wich was not installed via Plesk APS.

Resolution

Only applications that were installed via Plesk APS are supported:

http://www.odin.com/support/policies/support-scope/

Please contact your CMS vendor to resolve the issue on code level.

Have more questions? Submit a request
Please sign in to leave a comment.