Mcrypt module is not supported in PHP5.3 for CentOS 5

Created:

2016-11-16 13:08:51 UTC

Modified:

2017-08-08 13:24:10 UTC

1

Was this article helpful?


Have more questions?

Submit a request

Mcrypt module is not supported in PHP5.3 for CentOS 5

Applicable to:

  • Plesk 12.0 for Linux

Symptoms

Installation/upgrade by Autoinstaller stopped with the following error message:

Error: Unable to proceed with the installation until the package php-mcrypt-5.1.6-15.el5.centos.1.i386 is
removed from the system.
Not all packages were installed.
Please resolve this issue and try installing the packages again.

Cause

RedHat have not provided mcrypt module for php53.

Resolution

As a possible workaround, you should uninstall the package first:

# rpm -e php-mcrypt

Then you should install/upgrade Plesk by autoinstaller.After that you can use php53u-mcrypt - A module for PHP applications that use Mcrypt or build it by yourself.

Have more questions? Submit a request
Please sign in to leave a comment.