Failed to install the ModSecurity rule set: Unable to find row with id in domains table.

Created:

2016-11-16 13:08:48 UTC

Modified:

2017-08-08 13:16:35 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Failed to install the ModSecurity rule set: Unable to find row with id in domains table.

Applicable to:

  • Plesk Onyx for Windows
  • Plesk 12.5 for Windows

Symptoms

Unable to activate Tools & Settings > Web Application Firewall (ModSecurity) in Plesk with the following error:

Failed to install the Mod-security rule set: Unable to find row with id 221 in domains table.

Unable to use the current Apache configuration file and to roll back to the previous version of the file because they contain an invalid configuration.>

 Or

Db_Table_Exception: Unable to find row with id 221 in domains table.

Cause

Database inconsistency.

Resolution

Fix database inconsistency using Plesk self-repair tool.
Run from command line:

# plesk repair db

 

Have more questions? Submit a request

3 Comments

  • 0
    Avatar
    Lpeters

    Still getting the same error.

  • 0
    Avatar
    Artyom Baranov

    Hi!

    I'd like to investigate this issue deeper, so I will create a ticket for you.

     

  • 0
    Avatar
    G.V Reddy

    We had same issue.

    Failed to install the ModSecurity rule set: Unable to find row with id 11 in domains table.Unable to use the current ModSecurity rule set and to roll back to the previous version because they contain invalid rules.

    Below solution worked for me,

    Check whether the domain exists in the server with the same ID.

    mysql> select * from domains where id=916;
    Empty set (0.00 sec)

    Check whether the Application pool entry exists in 'IisAppPools' for that particular domain id.

    mysql> select id from IisAppPools where ownerId=916;
    +-----+
    | id |
    +-----+
    | 188 |
    +-----+
    1 row in set (0.00 sec)

    Remove record:

    mysql> delete from IisAppPools where ownerId=916;
    Query OK, 1 row affected (0.03 sec)

    Enable mod_security again.

    Edited by G.V Reddy
Please sign in to leave a comment.