Plesk upgrade to version 12 fails with error: A specified logon session does not exist. You may already have been terminated.

Created:

2016-11-16 13:08:09 UTC

Modified:

2017-08-16 18:35:39 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade to version 12 fails with error: A specified logon session does not exist. You may already have been terminated.

Applicable to:

  • Plesk 11.x for Windows
  • Plesk 12.0 for Windows

Symptoms

An attempt to upgrade Plesk to version 12 fails with the following error:

    Unable to execute "C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\bin\\websrvmng.exe" - configure-plesk-website:
A specified logon session does not exist. You may already have been terminated. (Exception from HRESULT: 0x80070520)
In Microsoft.Web.Administration modules
Exception type: System.Runtime.InteropServices.COMException
at Microsoft.Web.Administration.Interop.IAppHostMethodInstance.Execute ()
at Microsoft.Web.Administration.Binding.AddSslCertificate (Byte [] CertificateHash, String certificate gates name)

at Microsoft.Web.Administration.BindingManager.BindingTransaction.Commit ()
at Microsoft.Web.Administration.BindingManager.Save ()
at Microsoft.Web.Administration.ServerManager.CommitChanges ()
at ServerManagerFactory.commit ()
at IISServerManager.commit (IISServerManager *)

If you run mentioned command manually it fails with the same error.

Cause

Such situation may take a place when system cannot recreate Plesk certificate in IIS > Certificate .

Resolution

  1. Make sure that httpsd.pem files exists in C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\conf .

  2. Reconfigure Plesk site with Plesk Reconfigurator utlity: Plesk Reconfigurator > Repair Plesk installation > Plesk Services

Have more questions? Submit a request
Please sign in to leave a comment.