Error during the upgrade: "bind9 : Depends: libbind9-80 (= 1:9.8.1.dfsg.P1-4ubuntu0.6) but 1:9.8.1.dfsg.P1-4ubuntu0.7 is to be installed"

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:08:01 UTC

Modified:

2016-12-21 20:01:24 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Error during the upgrade: "bind9 : Depends: libbind9-80 (= 1:9.8.1.dfsg.P1-4ubuntu0.6) but 1:9.8.1.dfsg.P1-4ubuntu0.7 is to be installed"

Symptoms

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
---X--- `apt-get` output ---------------------
Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
bind9 : Depends: libbind9-80 (= 1:9.8.1.dfsg.P1-4ubuntu0.6) but 1:9.8.1.dfsg.P1-4ubuntu0.7 is to be installed
Depends: libdns81 (= 1:9.8.1.dfsg.P1-4ubuntu0.6) but 1:9.8.1.dfsg.P1-4ubuntu0.7 is to be installed
Depends: libisc83 (= 1:9.8.1.dfsg.P1-4ubuntu0.6) but 1:9.8.1.dfsg.P1-4ubuntu0.7 is to be installed
Depends: libisccc80 (= 1:9.8.1.dfsg.P1-4ubuntu0.6) but 1:9.8.1.dfsg.P1-4ubuntu0.7 is to be installed
Depends: libisccfg82 (= 1:9.8.1.dfsg.P1-4ubuntu0.6) but 1:9.8.1.dfsg.P1-4ubuntu0.7 is to be installed
Depends: liblwres80 (= 1:9.8.1.dfsg.P1-4ubuntu0.6) but 1:9.8.1.dfsg.P1-4ubuntu0.7 is to be installed
Depends: bind9utils (= 1:9.8.1.dfsg.P1-4ubuntu0.6) but 1:9.8.1.dfsg.P1-4ubuntu0.7 is to be installed

Cause

The root cause of the the issue is the currently installed bind packages dependencies. Dependency packages are of version: '1:9.8.1.dfsg.P1-4ubuntu0.7' but bind9 version is '1:9.8.1.dfsg.P1-4ubuntu0.6' .

Resolution

Reinstall correct bind9 version: '1:9.8.1.dfsg.P1-4ubuntu0.7' :

root@hosting:~# dpkg --remove --ignore-depends=bind9 bind9
root@hosting:~# apt-get install bind9
Have more questions? Submit a request
Please sign in to leave a comment.