Plesk upgrade failed: ERROR 1524 (HY000): Plugin 'Y' is not loaded

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:07:49 UTC

Modified:

2017-02-19 15:47:44 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade failed: ERROR 1524 (HY000): Plugin 'Y' is not loaded

Symptoms

Plesk upgrade failed with the following error:

ERROR 1524 (HY000): Plugin 'Y' is not loaded

In /var/log/mysqld.log log you can see corresponding warning message:

150824 20:12:02 [Warning] 'user' entry 'pma_YDHnd4Ja5pfe@localhost' has both a password and an authentication plugin specified. The password will be ignored.

Cause

Incorrect value in mysql database.

Resolution

  1. Create a backup of the mysql database:

    mysqldump -uadmin -p`cat /etc/psa/.psa.shadow` mysql > mysql.sql
  2. Check plugin value for the mentioned user:

    mysql> select plugin from mysql.user where User like '%pma_YDHnd4Ja5pfe%' \\G
    *************************** 1. row ***************************
    plugin: Y
    1 row in set (0.00 sec)
  3. Remove incorrect value by the following query:

    mysql> update mysql.user set plugin = '' where User like '%pma_YDHnd4Ja5pfe%';
    Query OK, 1 row affected (0.01 sec)
    Rows matched: 1 Changed: 1 Warnings: 0
Have more questions? Submit a request
Please sign in to leave a comment.