Applicable to:
- Plesk for Linux
- Plesk 11.x for Windows
- Plesk 11.x for Linux
- Plesk 12.0 for Linux
Symptoms
1) When I try to back up any subscription, the task fails with the following error:
Error: pmm utility 'PMMCli' raised an exception. Error code is: -1
See pmmcli.log to find out detailed information on this
The following command returns at least one row with the domain name:
"%plesk_bin%\\dbclient.exe" --direct-sql --sql="select domains.id, domains.name, clients.login from domains left join clients on clients.id=domains.cl_id where clients.login is NULL"
2) There is another possible symptom in Parallels Plesk Panel (Plesk) for Linux. In the backup logs (/usr/local/psa/PMM/logs/backup-2014-03-01-09-35-55-384/backup.log), you get the following error:
Runtime error: Unable to find Plesk versionfile: /usr/local/psa/version at /usr/local/psa/PMM/agents/PleskX/PleskVersion.pm line 18.
at /usr/local/psa/PMM/agents/PleskX/PleskVersion.pm line 18
Cause
-
The issue is caused by an inconsistency in the Plesk database.
-
The file
/usr/local/psa/version
is absent.
Resolution
-
Back up the database:
"%plesk_dir%\\MySQL\\bin\\mysqldump" -P8306 -uadmin -pPleskAdminPassword --databases psa > c:\\Users\\Administrator\\plesk_db_backup.sql
-
Set the Plesk Administrator as the owner of every domain, returned by the "
dbclient
" query in the Symptoms section of this article (replace N in the request with theid
of the domain):"%plesk_bin%\\dbclient.exe" --direct-sql --sql="update domains set cl_id = (select id from clients where login = 'admin') where id = N"
-
If the task fails in Plesk for Linux and the issue is not in the database, make sure that /usr/local/psa/version exists. It should have content like the below:
# cat /usr/local/psa/version
11.5.30 CentOS 6 115131204.15
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