Plesk upgrade failure: Fatal error during packages installation

Created:

2016-11-16 13:07:17 UTC

Modified:

2017-08-16 16:58:57 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade failure: Fatal error during packages installation

Applicable to:

  • Plesk 11.x for Linux

Symptoms

  1. Plesk upgrade fails with the following error:

    Fatal error during packages installation: [u'ERROR with rpm_check_debug vs depsolve:', 'psa-mail-driver-common conflicts with plesk-mail-mc-driver-12.0.18-cos6.build1200140606.15.x86_64', 'plesk-courier-imap-driver conflicts with plesk-mail-mc-driver-12.0.18-cos6.build1200140606.15.x86_64', 'psa-courier-imap conflicts with plesk-mail-mc-driver-12.0.18-cos6.build1200140606.15.x86_64', 'psa-courier-authlib conflicts with plesk-mail-mc-driver-12.0.18-cos6.build1200140606.15.x86_64', 'psa-qmail conflicts with plesk-mail-mc-driver-12.0.18-cos6.build1200140606.15.x86_64', 'psa-qmail-rblsmtpd conflicts with plesk-mail-mc-driver-12.0.18-cos6.build1200140606.15.x86_64', 'postfix conflicts with plesk-mail-mc-driver-12.0.18-cos6.build1200140606.15.x86_64', 'sw-msmtp conflicts with plesk-mail-qc-driver-12.0.18-cos6.build1200140717.18.x86_64', u'Please report this error at http://bugs.centos.org/set_project.php?project_id=19&ref=http://bugs.centos.org/bug_report_page.php?category=yum']
  2. sendmail package is present on the server:

    # rpm -qa | grep sendmail
    sendmail-8.14.4-8.el6.x86_64

Cause

Package sendmail-8.14.4-8.el6.x86_64 is installed on the server

Resolution

  1. Remove sendmail-8.14.4-8.el6.x86_64 :

    # rpm -e --nodeps sendmail
  2. Start the upgrade again:

    # /usr/local/psa/admin/bin/autoinstaller --debug
Have more questions? Submit a request
Please sign in to leave a comment.