After installtion of Plesk Mobile 1.3, the error appears in Plesk: PHP Runtime Notice: Declaration of RootLocation::accessItem() should be compatible with UIPointer

Created:

2016-11-16 13:06:39 UTC

Modified:

2017-04-24 11:57:31 UTC

0

Was this article helpful?


Have more questions?

Submit a request

After installtion of Plesk Mobile 1.3, the error appears in Plesk: PHP Runtime Notice: Declaration of RootLocation::accessItem() should be compatible with UIPointer

Applicable to:

  • Plesk 11.5 for Linux

Symptoms

After installation of Plesk Mobile 1.3, the following error appears in Plesk

    PHP Runtime Notice: Declaration of RootLocation::accessItem() should be compatible with UIPointer::accessItem($method, $mode = NULL)
Line: 49
File: /usr/local/psa/admin/plib/UIPointer.php
Stack Trace:
#0 Smb_Exception_Syntax::handleError(2048, Declaration of RootLocation::accessItem() should be compatible with UIPointer::accessItem($method, $mode = NULL), /usr/local/psa/admin/plib/UIPointer.php, 49, Array ([path_info] => /plesk/sessions/,[components] => Array ([0] => ,[1] => plesk,[2] => sessions))) called at [/usr/local/psa/admin/plib/UIPointer.php:49]
#1 UIPointer::parse() called at [/usr/local/psa/admin/plib/UIPointer.php:49]
#2 UIPointer::parse(/plesk/sessions/) called at [/usr/local/psa/admin/plib/cmd_loginup.php:154]
#3 onSessionCreated(1, admin) called at [/usr/local/psa/admin/plib/cmd_loginup.php:309]
#4 createSessionAdmin(admin, marilen05$, , , 1) called at [/usr/local/psa/admin/plib/cmd_loginup.php:68]
#5 createSession(admin, marilen05$, , ) called at [/usr/local/psa/admin/htdocs/login_up.php3:45]

Cause

Parallels Panel Mobile Center extension is corrupted or outdated.

Resolution

To fix the issue:

  1. Backup Plesk Mobile extension

    mv /usr/local/psa/admin/plib/modules/plesk-mobile /root
  2. Delete existing Plesk Mobile extension in Plesk Panel GUI (Panel -> Server Management -> Extensions ). Select Parallels Panel Mobile Center . Click Remove button.

  3. Install the latest Parallels Panel Mobile Center extension:

    http://autoinstall.plesk.com/extensions/packages/

The latest version is plesk-mobile-1.4

http://autoinstall.plesk.com/extensions/packages/plesk-mobile-1.4-win.zip

Download it to your workstation and then upload to the Plesk server clicking Add Extension button in in Plesk Panel GUI (Panel -> Server Management -> Extensions )

Have more questions? Submit a request
Please sign in to leave a comment.