Cannot access website behind NAT

Created:

2016-11-16 13:05:37 UTC

Modified:

2017-08-16 17:07:50 UTC

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Cannot access website behind NAT

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux

Symptoms

  • Server configured with Plesk NAT manager and domains are resolved properly to external IP address. However websites are not accessible from outside.

  • tcpdump command is not showing traffic from external IP addresses on the interface:

tcpdump -i eth0 -nl tcp port 80

Cause

Firewall misconfiguration

Resolution

1. Check NAT configuration for proper IP addresses mapping.

2. Check that there are no firewall restrictions for ports 80 and 443 between the client and the server.

It can be checked with following commands on the client Linux computer from outside:

# curl -vvv 1.2.3.4:80 | grep HTTP
* About to connect() to 1.2.3.4 port 80 (#0)
* Trying 1.2.3.4...

HTTP/1.1 200 OK
# curl -vvv 1.2.3.4:443 | grep HTTP
* About to connect() to 1.2.3.4 port 443 (#0)
* Trying 1.2.3.4...

HTTP/1.1 200 OK

3. Check that ports are opened using nmap utility on the linux computer from outside:

# nmap 1.2.3.5 -p80
PORT STATE SERVICE
80/tcp open http
# nmap 1.2.3.5 -p443
PORT STATE SERVICE
443/tcp open https

If ports are filtered or closed, it is needed to check Firewall settings on NAT/external Firewall side.

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