Postfix errors after Plesk upgrade: auxpropfunc error no mechanism available

Created:

2016-11-16 13:05:35 UTC

Modified:

2017-08-16 16:39:06 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Postfix errors after Plesk upgrade: auxpropfunc error no mechanism available

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.x for Linux
  • Plesk 12.0 for Linux

Symptoms

The following errors are shown in /var/log/messages file, does it affect mail service functionality?

www postfix/smtpd[6654]: SQL engine 'intentionally disabled' not supported
www postfix/smtpd[6654]: auxpropfunc error no mechanism available

Cause

No, the issue does not affect mail service functionality, sqlite plugin has been used in Plesk 10.x versions, but Plesk 11 uses its own SASL auxprop plugin. The issue may occur if after Plesk upgrade from 10.x version or lower.

Resolution

Such errors can be safely ignored, or or fixed with the following steps:

  1. Remove cyrus-sasl-sqlite3 package:

    For RedHat, CentOS, CloudLinux, SuSE:

    # rpm -e cyrus-sasl-sqlite3

    For Debian, Ubuntu:

    # dpkg --purge libsasl2-modules-sqlite3
  2. Restart Postfix service:

    # /etc/init.d/postfix restart

NOTE: If the package should be installed back for some reason, it can be found in Plesk repository, for example for CentOS 6, x86_64 and Debian 6.0, x86_64:

http://autoinstall.plesk.com/PSA_10.4.4/dist-rpm-CentOS-6-x86_64/contrib/cyrus-sasl-sqlite3-1.0.1-11080119.x86_64.rpm

http://autoinstall.plesk.com/PSA_10.4.4/dist-deb-Debian-6.0-x86_64/contrib/libsasl2-modules-sqlite3_1.0.1-11080119_amd64.deb

Have more questions? Submit a request
Please sign in to leave a comment.