Mail users cannot not receive messages: "Relay access denied"

Refers to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:04:34 UTC

Modified:

2017-02-14 22:14:21 UTC

1

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Mail users cannot not receive messages: "Relay access denied"

Symptoms

Messages are not being delivered to mail users in Plesk. The following error is shown in the " /usr/local/psa/var/log/maillog " log:

postfix/smtpd[9618]: connect from mail-ee0-f46.google.com
postfix/smtpd[9618]: NOQUEUE: reject: RCPT from mail-ee0-f46.google.com: 554 5.7.1 Relay access denied; from=<testmailforsmth@gmail.com> to=<admin@domain.tld> proto=ESMTP helo=<mail-ee0-f46.google.com>
postfix/smtpd[9618]: disconnect from mail-ee0-f46.google.com
/usr/lib64/plesk-9.0/psa-pc-remote[9425]: Message aborted.
/usr/lib64/plesk-9.0/psa-pc-remote[9425]: Message aborted.

Cause

There could be several possible causes for this issue:

  1. Postfix databases that contain information about the hosted mail domains\mailboxes are corrupted.
  2. The pc-remote service is not running:
    # /etc/init.d/pc-remote status
    psa-pc-remote is stopped
    1. Mail service is switched off for a domain, or the domain itself is disabled in Plesk.

Resolution

Use one of the following solutions depending on the root cause of your issue from above:

  1. Run the mchk utility to rebuild Postfix databases from scratch:
    /usr/local/psa/admin/sbin/mchk --without-spam
    1. Start the service:

      /etc/init.d/pc-remote start

      1. Check that 'Mail service' is enabled for the subscription at Subscription -> Mail -> Change Settings Activate mail service on domain . If it is not enabled, turn it on.
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