MailEnable mail stuck in outgoing queue: Could not resolve MX list for domain

Created:

2016-11-16 13:04:30 UTC

Modified:

2017-08-08 13:35:14 UTC

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MailEnable mail stuck in outgoing queue: Could not resolve MX list for domain

Applicable to:

  • Plesk 12.0 for Windows

Symptoms

Mail could not be delivered to remote server, stuck in the outgoing queue.

%plesk_dir%\\Mail Servers\\Mail Enable\\LOGGING\\SMTP\\SMTP-Debug-<datetime>.log file contains the following:

08/30/16 11:17:46   ME-E0124: Error (1460): Could not resolve MX list for domain [domain.tld]

Cause

DNS server configured in MailEnable could not resolve domain IP address.

Resolution

Configure DNS servers IP addresses to DNS list in MailEnable > Servers > localhost > Connectors > SMTP > General For an example, Google DNS servers IP could be added: 8.8.8.8 , 4.4.4.4

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