Plesk upgrade fails with error: Unable to determine version or build number of psa installed

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:04:29 UTC

Modified:

2017-01-26 10:44:32 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade fails with error: Unable to determine version or build number of psa installed

Symptoms

Upgrade to Plesk 12 fails with error below:

Error: An error occurred during performing of installation PREP actions (see log for details). Installation was rolled back.  
Warning! Not all packages were installed.

In /var/log/plesk/install/plesk_12.0.18_installation.log there is another error:

Unable to determine version or build number of psa installed

Cause

Missing or corrupted /usr/local/psa/core.version and /usr/local/psa/version files.

Resolution

  1. Make sure that both files exist and have correct permissions:

    # ls -la /usr/local/psa/version
    -rw-r--r-- 1 root root 30 24. Okt 00:03 /usr/local/psa/version

    # ls -la /usr/local/psa/core.version
    -rw-r--r-- 1 root root 30 24. Okt 00:03 /usr/local/psa/core.version
  2. Make sure that these files contain your current Plesk and OS version. For Plesk 11.5.30 . Example:

    # cat /usr/local/psa/version
    11.5.30 CentOS 6 115140407.17

    # cat /usr/local/psa/core.version
    11.5.30 CentOS 6 115140407.17
  3. Create missing file or correct improper one and launch autoinstaller again.

Have more questions? Submit a request
Please sign in to leave a comment.