Subscription can not be synchronized with the service plan: Unable to allocate the required amount of resources

Created:

2016-11-16 13:04:28 UTC

Modified:

2017-08-16 16:49:36 UTC

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Subscription can not be synchronized with the service plan: Unable to allocate the required amount of resources

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.x for Windows
  • Plesk 11.x for Linux
  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux
  • Plesk 12.5 for Windows

Symptoms

After upgrade or migration, subscription can not be synchronized with the service plan:

Unable to allocate the required amount of resources

Or

Synchronization failed

Unable to customize subscription properties:

Unable to allocate the required amount of resources (quantity Traffic). Only 211873590740 Traffic are available.
Unable to allocate the required amount of resources (quantity Mailbox size). Only 102400000 Mailbox size are available.
Unable to allocate the required amount of resources (quantity Subdomains). Only 48 Subdomains are available.
Unable to allocate the required amount of resources (quantity Disk space). Only 5242880000 Disk space are available.

The following warning is shown in Subscriptions > example.com > Customers :

Legacy Resources of Customer <customer_name>
This is not a subscription, it is a temporary entity created during the upgrade. It holds a former client limits and permissions they had in a previous version of Plesk. To make the customer completely fit in the Panel 10 business model, transition these resources and privileges.

Cause

Plesk 10 and later versions introduce a number of significant changes in the business model, for example, services are offered by means of service plans and subscriptions instead of templates and domains, and domain administrators are replaced with auxiliary users. Thus, if upgrade or migration was done from earlier versions of Plesk, transition to the new model is required.

Resolution

  1. Create a backup following instructions here:

A) Create a subscription backup on a source server, if required. Follow instructions in Plesk Administrator Guide .

B) Create database backup on a new server where issue occurred:

**Linux:**

# mysqldump -uadmin -p`cat /etc/psa/.psa.shadow ` psa > /tmp/psadump.`date +%F_%H.%M`.sql
# mysqldump -uadmin -p`cat /etc/psa/.psa.shadow ` --all-databases > /tmp/all.`date +%F_%H.%M`.sql

**Windows:**

"%plesk_dir%"\\Mysql\\bin\\mysqldump.exe -uadmin -p<plesk_admin_password> -P8306 DB_NAME > backup_name.sql
  1. Go to:

Subscriptions > example.com > click on Subscriber name > My resources

and click on "transition these resources and privileges"

  1. Synchronize subscription with the service plan.

Additional information

More details about transitioning are available in Plesk Deployment Guide .

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