Applicable to:
- Plesk for Linux
Symptoms
- Unable to receive/send e-mails from Plesk hosted on Amazon Lightsail/AWS EC2 or Microsoft Azure instance
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The following error can be found in
/var/log/maillog
when sending emails to an external domain:CONFIG_TEXT: dsn=4.4.1, status=deferred (connect to alt2.gmail-smtp-in.l.google.com[142.250.4.26]:25: Connection timed out)
- Email notifications from Advanced Monitoring not delivering.
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Outgoing mail connections via 25 port are not possible:
# telnet mail.example2.com 25
Trying 203.0.113.2...
telnet: connect to address 203.0.113.2: Connection timed out
Trying 2001:db8:f61:a1ff:0:0:0:80... telnet: connect to address 2001:db8:f61:a1ff:0:0:0:80 Network is unreachable. -
It is possible to send out an email message locally using the command:
# telnet localhost 25
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Notifications are received in regards to this port:
CONFIG_TEXT: You cannot send emails from Plesk because outbound connections on TCP port 25 is blocked. Check the firewall settings or contact your hosting provider.
Cause
SMTP ports are blocked by a firewall from Amazon side or on the server.
Resolution
-
For AWS instance, submit a request to AWS support to have port 25 unblocked in accordance with Amazon documentation or setup mail relay as shown in our free Udemy course.
Warning: If you have Amazon Lightsale please explicitly mention in the link above that you need to remove the port block for LightSale, otherwise AWS team will remove it for EC2 only.
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For Microsoft Azure, contact support at Subscription Management Problem type: Request to enable Port 25 email flow.
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If the Plesk Firewall is used, open mail port under Plesk > Tools & Settings > Firewall;
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If the system or a third party firewall is active on the server, make sure that it is not blocking the connection to the 25,465,995 ports.
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In case of an intermediate firewall, it is required to contact the service provider.
Additional information
Unable to send emails using Plesk local mail server: Connection timed out or connection refused. (#4.4.1)
Which Ports Need To Be Opened for all Plesk Services to Work with a Firewall?
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