Installing Plesk to Debian 7.0 based container fails: "Failed to fetch */NGINX*/Packages (404 Not Found)"

Refers to:

  • Plesk for Linux

Created:

2016-11-16 13:04:03 UTC

Modified:

2016-12-21 19:52:49 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Installing Plesk to Debian 7.0 based container fails: "Failed to fetch */NGINX*/Packages (404 Not Found)"

Symptoms

The task to install Plesk templates fails with the following error output:

Internal error: 3501 : Can not install packages: ' vzpkg install -q 9200 .pp11.5-webmail .pp11.5-webhosting-addons .pp11.5-watchdog .pp11.5-spamassassin .pp11.5-postfix .pp11.5-php5 .pp11.5-bind .pp11.5-panel-addons .pp11.5-migration .pp11.5-mailman .pp11.5' exec failed - W: Failed to fetch http://autoinstall.plesk.com/debian/NGINX1.5/dists/wheezy/all/binary-amd64/Packages 404 Not Found

Cause

The pp*-nginx application templates are outdated because Nginx has its own repository and separate application templates. Thus, such application templates are to be removed.

Resolution

Remove the pp*-nginx application templates from the server for all OS distributions and force an update of metadata from the server.

  1. Remove templates:

    ~# vzpkg list | awk '$2~/^pp.*-nginx$/{print$1" "$2}' | while read os app; do vzpkg remove template -F $os $app; done
  2. Update metadata, in this case for the debian-7.0-x86_64 OS template:

    ~# vzpkg update metadata debian-7.0-x86_64 -r
Have more questions? Submit a request
Please sign in to leave a comment.