Parallels Plesk Panel stops working after Zend Optimizer installation.

Created:

2016-11-16 13:03:43 UTC

Modified:

2017-04-24 11:58:52 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Parallels Plesk Panel stops working after Zend Optimizer installation.

Applicable to:

  • Plesk for Windows
  • Plesk 12.5 for Linux

Symptoms

Parallels Plesk Panel stops working after the installation of Zend Optimizer.

Cause

The reason for the problem is that Zend sets a path to the php.ini file in the registry:

HKEY_LOCAL_MACHINE\\SOFTWARE\\PHP\\IniFilePath=C:\\WINDOWS

Therefore, all .php scripts on the server start using this setting and use the C:\\WINDOWS\\php.ini file for PHP configuration.

Resolution

To fix this problem , the following key needs to be removed:

  • On x86 servers - HKEY_LOCAL_MACHINE\\SOFTWARE\\php\\IniFilePath
  • On x64 servers - HKEY_LOCAL_MACHINE\\SOFTWARE\\Wow6432Node\\PHP\\IniFilePath

Then, all .php scripts will use the correct .ini files.

Additional Information

Please alse see article #3041 .

Have more questions? Submit a request
Please sign in to leave a comment.