Switching Plesk maildriver on Linux by VZ templates failed.

Created:

2016-11-16 13:03:42 UTC

Modified:

2017-08-16 16:54:20 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Switching Plesk maildriver on Linux by VZ templates failed.

Applicable to:

  • Plesk 11.x for Linux

Symptoms

Switching Plesk maildriver on Linux by VZ templates
# vzpkg install CTID pp11.5-qmail
or
# vzpkg install CTID pp11.5-postfix
failed on dependencies resolving:

Error: plesk-mail-qc-driver conflicts with plesk-mail-pc-driver
Error: plesk-mail-pc-driver conflicts with plesk-mail-qc-driver
Error: plesk-mail-pc-driver conflicts with psa-qmail
Error: plesk-mail-pc-driver conflicts with psa-qmail-rblsmtpd

Cause

The cause is a bug in product(internal ID: 142461) which will be fixed in future releases.

Resolution

Switch maildriver using autoinstaller then install needed template and remove previously installed maildriver template:

In case of switching from postfix to qmail:
# vzctl exec CTID /usr/local/psa/admin/sbin/autoinstaller --select-release-current --install-component qmail; vzpkg install CTID pp11.5-qmail; vzpkg remove CTID pp11.5-postfix

In case of switching from qmail to postfix:
# vzctl exec CTID /usr/local/psa/admin/sbin/autoinstaller --select-release-current --install-component postfix; vzpkg install CTID pp11.5-postfix; vzpkg remove CTID pp11.5-qmail

Have more questions? Submit a request
Please sign in to leave a comment.