Unable to install application: The app requires the mysql database server version 5.1 or later

Created:

2016-11-16 13:03:23 UTC

Modified:

2017-08-08 13:46:04 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to install application: The app requires the mysql database server version 5.1 or later

Symptoms

Unable to install application WordPress:

Unable to install the app because its installation requirements are not met. Contact your hosting provider to resolve this problem. 
The app requires the mysql database server version 5.1 or later.

Cause

1) Mysql server is not configured for a subscription

2) Mysql version is lower than 5.1.

3) Mysql is not enabled

Resolution

1) By default Plesk uses Default Mysql Server. If there are other registered Mysql Servers in Tools and Settings > Database Servers, specify it for a subscription:

    # /usr/local/psa/bin/subscription_settings -u domain.tld -default_server_mysql 1.2.3.4:3306

where domain.tld is the subscription name and 1.2.3.4 is the IP Address of the registered Mysql Server

2) Make sure that Mysql version is 5.1:

    # mysql -V
mysql Ver 14.14 Distrib 5.1.69,

# rpm -qa | grep mysql
mysql-5.1.69-1.el6_4.x86_64
mysql-server-5.1.69-1.el6_4.x86_64

3) Make sure mysql is enabled in Tools and Settings > Database Servers

Have more questions? Submit a request
Please sign in to leave a comment.