Plesk packages are removed after PHP upgrade

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:03:21 UTC

Modified:

2017-02-13 09:34:31 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk packages are removed after PHP upgrade

Symptoms

PHP was manually upgraded, after that Plesk is not loading.

OR

Sendmail was installed, that caused Plesk 10 packages removal. Plesk GUI is accessible, however, it is not possible to delete a subscription.

Cause

Plesk packages were removed during installation or upgrading of another packages. The following entries can be found in ' /var/log/yum.log ':

Apr 09 18:53:43 Erased: psa11-php-fakepackage
Apr 09 18:53:57 Erased: psa-imp
Apr 09 18:54:14 Erased: php53-mysql
Apr 09 18:54:20 Erased: plesk-l10n
Apr 09 18:54:22 Erased: psa-migration-manager
Apr 09 18:54:23 Erased: psa-mimp
Apr 09 18:54:24 Erased: psa-backup-manager
Apr 09 18:54:25 Erased: php53-xml
Apr 09 18:54:25 Erased: psa-php53-configurator
Apr 09 18:54:25 Erased: php5-ioncube-loader
Apr 09 18:54:28 Erased: psa-mnemo
Apr 09 18:54:29 Erased: php53-gd
Apr 09 18:54:29 Erased: php53
Apr 09 18:54:29 Erased: psa-migration-agents
Apr 09 18:54:29 Erased: psa
Apr 09 18:54:29 Erased: php53-cli
Apr 09 18:54:31 Erased: psa-firewall
Apr 09 18:54:31 Erased: psa-updates
Apr 09 18:54:31 Erased: psa-vhost
Apr 09 18:54:46 Erased: plesk-core
Apr 09 18:54:48 Erased: psa-passwd
Apr 09 18:54:48 Erased: php53-sqlite2
Apr 09 18:55:04 Erased: pp-sitebuilder
Apr 09 18:55:12 Erased: psa-horde
Apr 09 18:55:13 Erased: php53-mbstring
Apr 09 18:55:14 Erased: psa-kronolith
Apr 09 18:55:15 Erased: php53-common
Apr 09 18:55:15 Erased: psa-libxml-proxy
Apr 09 18:55:15 Erased: php53-pdo
Apr 09 18:55:15 Erased: php53-imap
Apr 09 18:55:16 Erased: psa-ingo
Apr 09 18:55:17 Erased: psa-turba
Apr 09 18:58:02 Installed: php55w-common-5.5.23-1.w5.x86_64
Apr 09 18:58:08 Installed: libedit-2.11-2.20080712cvs.el5.x86_64
Apr 09 18:58:09 Installed: php55w-cli-5.5.23-1.w5.x86_64
Apr 09 18:58:09 Installed: php55w-5.5.23-1.w5.x86_64
Apr 09 20:10:49 Updated: libgcc-4.1.2-55.el5.x86_64
Apr 09 20:10:49 Updated: setup-2.5.58-9.el5.noarch
Apr 09 20:10:49 Updated: rmt-0.4b41-6.el5.x86_64
Apr 09 20:10:50 Updated: kernel-headers-2.6.18-404.el5.x86_64

Resolution

  1. Disable the internal autoinstaller package resolver:

    # echo 'USE_YUM="YES"' >> /root/.autoinstallerrc
  2. Download autoinstaller from http://autoinstall.plesk.com/

  3. Make the installer executable:

    # chmod +x plesk_installer
  4. Start the installer and install the missing packages (they will be chosen for installation automatically).

Additional

Note that after reinstalling Plesk packages, security key might be regenerated. It will make decrypting old passwords impossible. The passwords can be reset as described in the following KB article .

Have more questions? Submit a request
Please sign in to leave a comment.