Spam folder not being created: Unable to delivery message into Spam folder

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 10.4 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:03:12 UTC

Modified:

2016-12-21 19:50:39 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Spam folder not being created: Unable to delivery message into Spam folder

Symptoms

For some users, Spamassassin does not filter messages and the following errors are shown in maillog ($PRODUCT_ROOT_D/var/log/maillog):

spamd[4448]: spamd: result: Y 5 - ALL_TRUSTED,DRUGS_ERECTILE,DRUG_ED_CAPS,SUBJ_ALL_CAPS,UPPERCASE_75_100 scantime=0.4,size=3621,user=example@parallels.com,uid=30,required_score=1.0,rhost=localhost,raddr=127.0.0.1,rport=60326,mid=<20131224171121.Horde.MSo6LK_D4PwuPHWXWt3szw8@webmail.parallels.com>,autolearn=no
spamd[4435]: prefork: child states: I
spam_hook[6442]: Exiting with exit code: 75
spam_hook[6442]: Unable to delivery message into Spam folder
postfix-local[6441]: Error during 'spam' handler
postfix/pipe[6440]: 8611942C2D: to=<example@parallels.com>, relay=plesk_virtual, delay=0.71, delays=0.16/0/0/0.55, dsn=2.0.0, status=sent (delivered via plesk_virtual service)

Cause

Spamassassin folder( .Spam ) has been removed from the mailbox folder. It possible if end user renamed/removed spam directory in Webmail:

/var/qmail/mailnames/parallels.com/example/Maildir
[root@parallels Maildir]# ls -la
total 40
drwx------ 8 popuser popuser 4096 Dec 25 01:07 .
drwx------ 5 popuser popuser 4096 Dec 25 01:07 ..
drwx------ 2 popuser popuser 4096 Dec 24 23:54 courierimapkeywords
-rw-r--r-- 1 popuser popuser 0 Dec 25 01:06 courierimapsubscribed
-rw-r--r-- 1 popuser popuser 172 Dec 25 00:12 courierimapuiddb
drwx------ 2 popuser popuser 4096 Dec 25 01:01 cur
-rw-r--r-- 1 popuser popuser 31 Dec 25 01:07 maildirsize
drwx------ 2 popuser popuser 4096 Dec 25 00:12 new
drwx------ 6 popuser popuser 4096 Dec 24 23:56 .Sent
drwx------ 2 popuser popuser 4096 Dec 25 01:07 tmp

Resolution

In order to fix this issue you should restore mailbox structure of your mail account. To perform this operation you could use Command-Line utility mchk :

[root@parallels]# /usr/local/psa/admin/sbin/mchk --with-spam
==> Checking for: mailsrv_conf_init... ok
==> Checking for: mail_handlers_init... ok
==> Checking for: mailsrv_entities_dump... ok
==> Checking for: mail_admin_aliases... ok
==> Checking for: mail_auth_dump... ok
==> Checking for: mailman_lists_dump... ok
==> Checking for: mail_kav8_restore... ok
==> Checking for: mail_responder_restore... ok
==> Checking for: vhostidmng... ok
==> Checking for: mail_postfix_transport_restore... ok
==> Checking for: mail_spam_restore... ok
==> Checking for: mail_grey_restore... ok
==> Checking for: mail_mailbox_restore... ok
==> Checking for: mail_spf_restore... ok
==> Checking for: mail_dk_restore... ok
==> Checking for: mail_drweb_restore... not exists

Or you can run mail_mailbox_restore utility separately:

/usr/lib64/plesk-9.0/mail_mailbox_restore --all
Have more questions? Submit a request
Please sign in to leave a comment.