admin can not see File tab and Database link of customer's subscriptions

Refers to:

  • Plesk 11.5 for Linux
  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:03:03 UTC

Modified:

2016-12-21 19:50:13 UTC

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admin can not see File tab and Database link of customer's subscriptions

Symptoms

Plesk administrator can not see Files tab and Database link of customer's subscriptions.

Cause

Owner of subscription doesn't have permissions Create and manage databases and Upload and manage files .

This issue has been considered as software issue #PPPM-2008 and will be fixed in future Plesk updates.

Resolution

  1. Check Customer permissions under:

    Home > Subscriptions > <subscription_name> > Users
  2. Click on with role Owner to check whether the Owner has permissions Create and manage databases and Upload and manage files .

  3. Assing to Owner missing permissions:

Use the following command:

    # /usr/local/psa/bin/role --update Owner -owner <customer's_username> -databasesManagement true -filesManagement true

Use option --help for more information:

    # /usr/local/psa/bin/role --help
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