'Internal error: Access denied' when trying to access Plesk web GUI File Manager after reconfiguring the permissions for FTP

Refers to:

  • Plesk 11.5 for Windows
  • Plesk 12.0 for Windows
  • Plesk 12.5 for Windows
  • MG:08de2fdaabcd120b8ca1388d21179921
  • MT:90145fdbae33b067a8d11f6da936808a

Created:

2016-11-16 13:02:42 UTC

Modified:

2017-02-19 18:49:27 UTC

0

Was this article helpful?


Have more questions?

Submit a request

'Internal error: Access denied' when trying to access Plesk web GUI File Manager after reconfiguring the permissions for FTP

Symptoms

Unable to access the files and folders through Plesk GUI File Manager. It fails with the following error message:

Error

Internal error: Access denied
Message: Access denied
File: Windows.php
Line: 525
Type: PleskUtilException

Same error as in the article #122415 but every time I reconfigure permissions for this domain (or add another FTP user for it), they are set to wrong values.

Before creating/removing an ftp account, some new folder was created in the webspace folder, after that ' %plesk_cli%\\repair.exe ' utility was called with ' --repair-webspace-security ' option.

Cause

' %plesk_cli%\\repair.exe ' utility with ' --repair-webspace-security ' option corrupts %plesk_vhosts%example.com\\.plesk\\.Security file which is used for updating file permissions on the webspace files.

This behavior has been submitted to Plesk Service Team as a software issue with internal ID #PPPM-3043 . It will be fixed in future Plesk updates.

Resolution

As a workaround, it is needed to remove the directory which caused the issue, and to run

> `%plesk_cli%\\repair.exe` --repair-webspace-security -webspace-name example.com

The issue is not supposed to occur on not affected subscriptions if ' %plesk_cli%\\repair.exe ' utility is not called with ' --repair-webspace-security ' option for the webspace after creating new folder.

Have more questions? Submit a request
Please sign in to leave a comment.