Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
Unable to add more than 100 email addresses to SpamAssassin White/Black List in Tools & Settings > Spam Filter > Black/White list or in Domains > example.com > Mail > Email Addresses > john.doe@example.com > Spam Filter. One of the following messages are shown in Plesk interface:
PLESK_WARN: Warning: Only 100 first unique e-mail addresses will be added
PLESK_ERROR: Only 100 unique email addresses can be added
PLESK_ERROR: ERR [1] PleskUtilException: spammng failed:
file: /usr/local/psa/admin/plib/Service/Agent.php
line: 228
code: 0
Cause
SpamAssassin limitation does not allow add more then 100 emails.
Resolution
NOTE: Large number of addresses in the SpamAssassin white/black lists may significantly reduce server performance.
- Connect to the server using SSH;
- Create a backup of Plesk database;
-
Run the following commands to set maximum number of addresses. As an example, the maximum number of 150 mail addresses is given: you may choose appropriate number according to your needs.
For Plesk Onyx:
# plesk db "replace into ServiceNodeConfiguration values (1, 'mailServer', 'spamfilter_max_addr_list_length', 150);"
For Plesk Obsidian:
# plesk bin settings --set spamfilter_max_addr_list_length=150
Comments
4 comments
It's not fixed in Plesk Obsidian, I've just tested the last version and has the same problem!
Hello @Joan Roca,
Thank you for your input!
The article was modified accordingly.
I am trying to increase this limit in Obsidian. Even with the ssh code the limitation continues. Tryed inserting the database entry and it doesn't work ether.
So what's the solution?
I'm with the Plesk Obsidian 18.0.25 Update #2.
Hi Jonathan Jandrey Borges, if you do not see the setting added to "plesk bin settings" please open a support ticket with us. I just tested it and it works fine: https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support-
Please sign in to leave a comment.