How to increase the maximum number of addresses that can be added to the SpamAssassin White or Black list

Created:

2016-11-16 13:02:09 UTC

Modified:

2017-03-28 11:31:56 UTC

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How to increase the maximum number of addresses that can be added to the SpamAssassin White or Black list

Symptoms

Unable to add more than 100 email addresses to SpamAssassin White List or Black List through Plesk interface:

Home > Tools & Settings > Spam Filter Settings

or

Home > Subscriptions > <domain.tld> > Mail > Email Addresses > <email@domain.tld> > Spam Filter (this tab will be available if SpamAssassin is installed).

After 100 addresses are added, the following notification is received:

Error: Only %available%% unique email addresses can be added.

or

Warning: Only 100 first unique e-mail addresses will be added.

Cause

Plesk has a default limit on the number of email addresses that can be added into SpamAssassin black/white lists. This is because a large number of addresses in the SpamAssassin white/black list may significantly reduce server performance.

Resolution

  1. For Plesk 11.0 and earlier , use the following SQL query to set the maximum number of addresses to 150:

    #  MYSQL_PWD=`cat /etc/psa/.psa.shadow` mysql -u admin psa -e "replace into misc values('spamfilter_max_addr_list_length', 150);"
  2. Since Plesk 11.5 some configuration settings were moved from the misc table. To increase the limit on the number of email addresses in SpamAssassin white/black lists use the following SQL query:

    #  MYSQL_PWD=`cat /etc/psa/.psa.shadow` mysql -u admin psa -e "replace into ServiceNodeConfiguration values (1, 'mailServer', 'spamfilter_max_addr_list_length', 150);"

More information about SpamAssassin can be found in Plesk Administrator's Guide .

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