Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
Performing one of the following operations in Plesk:
- Accessing Plesk GUI
- Opening WordPress Toolkit
- Opening ImunifyAV extension
- Scheduling a task
A blank page or one of the following errors might appear in Plesk GUI:
CONFIG_TEXT: ERROR: Allowed memory size of 16777216 bytes exhausted (tried to allocate 86 bytes)
CONFIG_TEXT: ERROR: Out of memory (allocated 23855104) (tried to allocate 12975879 bytes) (Abstract.php:41)
CONFIG_TEXT: Error 500
-
The following errors can be found in Plesk log file:
-
On Linux:
/var/log/plesk/panel.log
-
On Windows Server:
%plesk_dir%\admin\log\php_error.log
CONFIG_TEXT: PHP Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 52198551 bytes) in C:\Program Files (x86)\Parallels\Plesk\admin\plib\CommonPanel\Exception.php on line 58
ERR [1] ERROR: Allowed memory size of 268435456 bytes exhausted (tried to allocate 52198551 bytes) (Exception.php:58) -
Cause
Memory limit is exceeded by Plesk PHP back-end. This may happen if an object, over which the operation was performed, has a complex structure.
Resolution
-
Connect to the Plesk server via SSH (Linux) or via RDP (Windows).
-
Open the Plesk PHP configuration file php.ini in a text editor and increase the
memory_limit
size:-
On Linux:
CONFIG_TEXT: /usr/local/psa/admin/conf/php.ini
-
On Windows Server:
CONFIG_TEXT: %plesk_dir%admin\conf\php.ini
-
-
Restart the Plesk management service:
-
On Linux:
# service sw-engine restart
# service sw-cp-server restart -
On Windows Server:
Start PowerShell and run the commands one by one:
PS import-module WebAdministration
net stop "Plesk PopPass Service"
net stop "Plesk Management Service"
net start "Plesk Management Service"
net start "Plesk PopPass Service"
Restart-WebAppPool PleskControlPanel
-
Comments
4 comments
I have increased the limit from 256M to 512M.
@Gianluca, which limit have you specified when applying the solution?
There is a possibility that specified limit was not enough.
I had this issue trying to delete a subscription, i followed this guide but it seems the restart of the Plesk management service does not "read" the new php.ini, in fact after the modification i tried again to delete the subscritpion but the error was the same.
Then i tried to restart Plesk services by "Plesk service monitor": i restarted the entire "Plesk run-time" and "Mail service" then tried to delete the subscription again, no luck.
Finally i restarted the server and finally i was able to delete the subscription.
@Gianluca, thank you for the provided info.
If the issue will reoccur, increase the limit further. In case it would not help, consider submitting a ticket to Plesk Technical Support.
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