Website does not work properly after transferring to Plesk 11.5 from 10.4.4

Created:

2016-11-16 13:01:49 UTC

Modified:

2017-08-16 18:27:32 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Website does not work properly after transferring to Plesk 11.5 from 10.4.4

Applicable to:

  • Plesk 11.x for Linux
  • Plesk 12.0 for Linux

Symptoms

Website does not work properly after transferring to Plesk 11.5 from 10.4.4 where were no issues.

Cause

Most PHP versions are not backward compatible, for example, 5 is not compatible with 4, 5.2 with 5.1, and so on. For example, a web app that requires PHP 4 might not work with PHP 5.3 supplied with Panel 11.5. To avoid this, Panel allows you to install any PHP version on the server in addition to the supplied one. After registering this version in Panel, you can set it as default for certain service plans or any website in Panel. Customers with the Hosting settings management permission will be able to specify PHP version for a particular website.

Resolution

Using Multiple PHP Versions in Panel on Linux

On Linux systems, you can install any PHP version you need and then make it available in Panel by registering it with the php_handler command line utility.

Using Multiple PHP Versions in Panel on Windows

To get more details follow to official documentation .

All up-to-date and commonly used versions of PHP are shipped with Panel and can be installed through

Tools & Settings > Updates and Upgrades > Add/Remove components

You can specify a certain PHP version for a service plan and for a website in their hosting settings in PHP support > PHP version :

Version 4.x is outdated, use it only if you need to host old PHP application versions.
Version 5.x is current and its use is recommended.

To get more details follow the official documentation .

Have more questions? Submit a request
Please sign in to leave a comment.