Cannot install Wordpress version 3.4.2 or earlier : WP-CLI needs WordPress 3.7 or later to work properly

Created:

2016-11-16 13:00:49 UTC

Modified:

2017-08-08 13:12:25 UTC

1

Was this article helpful?


Have more questions?

Submit a request

Cannot install Wordpress version 3.4.2 or earlier : WP-CLI needs WordPress 3.7 or later to work properly

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 12.5 for Windows

Symptoms

Cannot install/update WordPress. An error occurs:

...
{"err_code":10002,"err_message":"WP-CLI needs WordPress 3.7 or later to work properly. The version currently installed is 3.4.2.\

Try running wp core download --force ."} ...

Cause

In order to manage WordPress installations in Plesk, the installation version should be 3.7 or higher, because Plesk uses WP-CLI and WP-CLI’s minimum supported WordPress version is 3.7: Changes to supported versions

Resolution

Upgrade WordPress to version 3.7 or higher. Detailed instructions can be found in official WordPress documentation: Updating WordPress

If there are no WordPress instances that are using WordPress Toolkit, it can be disabled by adding the following to panel.ini file:

[wpToolkit]
enabled=off

and installing WordPress via Applications tab.

Have more questions? Submit a request
Please sign in to leave a comment.