Fail2ban or Modsecurity are missing in Plesk 12 after upgrade

Created:

2016-11-16 13:00:39 UTC

Modified:

2017-08-16 17:17:38 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Fail2ban or Modsecurity are missing in Plesk 12 after upgrade

Applicable to:

  • Plesk for Windows
  • Plesk 12.5 for Linux
  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux

Symptoms

Features are missing in Plesk 12 after upgrade, such as Fail2ban or Modsecurity.

Cause

Issue with the license used on a server.

Resolution

Plesk 12 and Plesk 10/11 Lease licenses used on Plesk 12 server support Fail2ban and Modsecurity.

Make sure the correct license is uploaded. Go to Tools and Settings > License Management > Retrieve . This way, you will upload the last license file. If your license is up-to-date and Fail2ban or Modsecurity components are still not visible in the panel and cannot be installed in Updates and Upgrades menu, check what license number you are using and contact Plesk licensing support .

As a temporary solution, obtain and install a trial license of Plesk 12:

Have more questions? Submit a request
Please sign in to leave a comment.