Support for mod_python, Apache ASP, and Miva Merchant software

Created:

2016-11-16 13:00:00 UTC

Modified:

2017-08-08 13:23:06 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Support for mod_python, Apache ASP, and Miva Merchant software

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux
  • Plesk 12.0 for Linux

Symptoms

  • mod_python, mod_aspdotnet Apache modules are not installed on CentOS 7, but the following options are available in Plesk:

    • Python support
    • Apache ASP support
    • Miva support
  • It is not possible to create domain with any of these modules.

  • It is not possible to migrate domains from a server with any Linux operating system other than CentOS 7 with any of these modules.

Cause

Plesk 12 and above on CentOS 7 does not support mod_python, Apache ASP, and Miva Merchant software.

Apache's mod_python and mod_aspdotnet modules are no longer supported by httpd project according to the Apache official website.

Resolution

Consider using mod_wsgi which is part of CentOS and also allows Python apps to run under Apache.

These modules are no longer supported starting from Plesk 12 and above on CentOS 7.

For more information, see Release notes.

Have more questions? Submit a request
Please sign in to leave a comment.