Plesk 12 on Centos 7 - 'Python support', '' available in 'Hosting parameters' of Service Plan

Refers to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:00:00 UTC

Modified:

2016-12-21 19:43:41 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk 12 on Centos 7 - 'Python support', '' available in 'Hosting parameters' of Service Plan

Symptoms

  • mod_python , mod_aspdotnet Apache modules are not installed on CentOS 7, but the following checkboxes are avaliable:

    • Python support
    • Apache ASP support
    • Miva support
  • It is not possible to create domain with any of these modules

  • It is not possible to migrate domain from server with any Linux operating system other than CentOS 7 with any of these modules.

Resolution

Apache's mod_python , mod_aspdotnet modules are no longer supported by httpd project according to the Apache official website .

Consider using mod_wsgi which is part of CentOS and also allows Python apps to run under Apache.

These modules are no longer supported by Plesk 12 on CentOS 7 as well. Please check our Release notes .

Have more questions? Submit a request
Please sign in to leave a comment.