Error during backup: Unable to get APS instances on webspace id <id>

Created:

2016-11-16 12:59:23 UTC

Modified:

2017-04-24 12:01:05 UTC

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Error during backup: Unable to get APS instances on webspace id <id>

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 10.4 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Windows
  • Plesk 11.5 for Linux
  • Plesk
  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux

Symptoms

A backup returns the following error message:

 Unable to get APS instances on webspace id 1234 (ErrorCode: 255, STDOUT:). Unable to get APS instances on webspace id 123 (ErrorCode: 255, STDOUT:).

The detailed error description contains this XML output:

<?xml version="1.0" encoding="UTF-8"?>
<execution-result status="error" log-location="/opt/psa/PMM/sessions/2013-12-22-000402.371/migration.result">
<object name="client_name" type="client">
<object name="domain.tld" type="domain">
<message id="5cf7c4e9-8973-433f-86d1-baf00c73595c" severity="error" code="UtilityError">
<description>Unable to get APS instances on webspace id 1234 (ErrorCode: 255, STDOUT:).</description>
</message>
</object>
</object>
<object name="client2_name" type="client">
<object name="domain2.tld" type="domain">
<message id="5c23ad5d-365a-4710-869d-66061ff54d37" severity="error" code="UtilityError">
<description>Unable to get APS instances on webspace id 123 (ErrorCode: 255, STDOUT:).</description>
</message>
</object>
</object>
</execution-result>

Cause

This is caused by a database inconsistency (extra records in the 'apsContextsApplications' table for corrupted APS applications).

Resolution

Find the invalid entries in the PSA database for the APS application:

mysql> select * from apsContexts where pleskId=1234;
+-----+-----------+---------+-------+----------------+
| id | pleskType | pleskId | ssl | subscriptionId |
+-----+-----------+---------+-------+----------------+
| 424 | hosting | 1234 | false | 558 |
+-----+-----------+---------+-------+----------------+
1 row in set (0.00 sec)

mysql> select * from apsContexts where pleskId=123;
+-----+-----------+---------+------+----------------+
| id | pleskType | pleskId | ssl | subscriptionId |
+-----+-----------+---------+------+----------------+
| 307 | hosting | 123 | true | 0 |
+-----+-----------+---------+------+----------------+
1 row in set (0.00 sec)

mysql> select * from apsContextsApplications where apsContextId=424;
+-----+--------------+--------------------------------------+
| id | apsContextId | registryApplicationId |
+-----+--------------+--------------------------------------+
| 508 | 424 | 07962984-6ec7-4755-9172-e090f972b0a8 |
+-----+--------------+--------------------------------------+
1 row in set (0.00 sec)

mysql> select * from apsContextsApplications where apsContextId=307;
+-----+--------------+--------------------------------------+
| id | apsContextId | registryApplicationId |
+-----+--------------+--------------------------------------+
| 368 | 307 | 24dc9a3d-b249-45c1-9e0c-1fb4fef948e7 |
+-----+--------------+--------------------------------------+
1 row in set (0.00 sec)

mysql> delete from apsContextsApplications where id=508;
Query OK, 1 row affected (0.12 sec)

mysql> delete from apsContextsApplications where id=368;
Query OK, 1 row affected (0.11 sec)

Note: Please make a backup of the PSA and APSC databases before applying the above solution.

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