MagicSpam activation error: Error retrieving version from PP API: Permission denied

Created:

2016-11-16 12:59:14 UTC

Modified:

2017-08-16 15:57:38 UTC

0

Was this article helpful?


Have more questions?

Submit a request

MagicSpam activation error: Error retrieving version from PP API: Permission denied

Applicable to:

  • Plesk 11.x for Linux

Symptoms

Unable to activate MagicSpam license:

Error retrieving version from Plesk API: Permission denied</font></span>

The same error is shown when checking the license key status with the command line utility:

# /usr/share/magicspam/bin/license_manager state

Cause

The issue applies to Plesk 11.x servers that were upgraded from version 8.x. In version 8, the "admin" user had an ID of "1" and was absent from the psa.clients table. After the upgrade, however, that user is added to the mentioned table with an ID other than "1," and PP starts using the "1" ID for API authentication.

Resolution

Issue is fixed in the latest Plesk versions. Upgrade to Plesk 11.5 or later.

Additional Information

For more information on using Secret Key Authentication, please check the API RPC Manual for Parallels Plesk Panel 11.0:

Have more questions? Submit a request
Please sign in to leave a comment.