Applicable to:
- Plesk 12.5 for Linux
Symptoms
- SMTP outgoing connection over TLS does not work in Outlook.
- The following error can be found in
/var/log/maillog
:
CONFIG_TEXT: SSL_accept error from unknown[203.0.113.2]: lost connection
lost connection after CONNECT from unknown[203.0.113.2] - Plaintext authorization is disabled:
# less /etc/postfix/main.cf | grep "smtpd_sasl_security_options"
smtpd_sasl_security_options = noplaintext - Errors like the following are logged into
/var/log/maillog
:
CONFIG_TEXT: mail postfix/smtpd[6814]: warning: SASL authentication failure: realm changed: authentication aborted
mail postfix/smtpd[6814]: warning: 203.0.113.2.example.com[203.0.113.2]: SASL DIGEST-MD5 authentication failed: authentication failure
Cause
Outlook is not compatible with CRAM-MD5 authentication mechanism.
Resolution
Allow plaintext authentication in Postfix:
- Connect to the server using SSH.
- Comment out the following line in
/etc/postfix/main.cf
by putting "#" in the beginning of it:
CONFIG_TEXT: #smtpd_sasl_security_options = noplaintext
- Restart postfix to apply configuration changes:
# service postfix restart
Comments
4 comments
Hi,
I get this type of error in logs from other smtp/mail servers that cannot communicate with our Plesk mail server.
SSL_accept error from unknown[203.0.113.2]: lost connection
lost connection after CONNECT from unknown[203.0.113.2]
I there any handshake problem?
I have grep 'smtpd_tls_mandatory_protocols' /etc/postfix/main.cf
smtpd_tls_mandatory_protocols = TLSv1 TLSv1.1 TLSv1.2
Regards, Miha
Hello @Miha, please, try the solution from this article.
Hi,
thx, I will try to reinastall ca-certificates. Is plesk repair mail needed?
Regards, Miha
@Miha
Yes, it is required to repair mail server configuration.
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