SMTP outgoing connection over TLS does not work in Outlook: lost connection lost connection after CONNECT from unknown

Created:

2016-11-16 12:59:00 UTC

Modified:

2017-08-16 04:22:35 UTC

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SMTP outgoing connection over TLS does not work in Outlook: lost connection lost connection after CONNECT from unknown

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

SMTP outgoing connection over TLS does not work in Outlook.

The following error can be found in /var/log/maillog :

PLESK_INFO: SSL_accept error from unknown[203.0.113.2]: lost connection
lost connection after CONNECT from unknown[203.0.113.2]

Plaintext authorization is disabled:

# less /etc/postfix/main.cf | grep "smtpd_sasl_security_options"`
smtpd_sasl_security_options = noplaintext

Errors like the following are logged into /var/log/maillog :

PLESK_INFO: mail postfix/smtpd[6814]: warning: SASL authentication failure: realm changed: authentication aborted
mail postfix/smtpd[6814]: warning: 203.0.113.2.example.com[203.0.113.2]: SASL DIGEST-MD5 authentication failed: authentication failure

Cause

Outlook is not compatible with CRAM-MD5 authentication mechanism.

Resolution

Allow plaintext authentication in Postfix:

1. Login to the server over SSH

2. Comment out the folllowing in /etc/postfix/main.cf :

CONFIG_TEXT:  smtpd_sasl_security_options = noplaintext

3. Apply configuration changes:

# /etc/init.d/postfix restart

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