SpamAssassin does not mark some messages as a SPAM

Created:

2016-11-16 12:58:46 UTC

Modified:

2017-08-16 18:32:52 UTC

0

Was this article helpful?


Have more questions?

Submit a request

SpamAssassin does not mark some messages as a SPAM

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.x for Windows
  • Plesk 12.0 for Windows

Symptoms

SpamAssassin does not mark spam messages as a spam, but it marks them along with non-spam mail if sensitivity is increased.

Cause

SpamAssassin Bayes filter doesn't have enough information to mark some messages as a spam.

Resolution

All spam messages should be placed into 'spamlearn' or 'spam' mail folders in order to be used for training. And in the next time when daily script will run, Plesk will train SpamAssassin on the messages located in these mail folders.

Note: According to the SpamAssassin documentation the Bayes system is not activated until a certain number of ham (non-spam) and spam has been learned. The default is 200 of each ham and spam messages. It means that SpamAssassin begins to filter mails (according to your trainings) after 200 spam mails and 200 none spam mails were learned. This statistics is needed to distinguish spam mails.

Have more questions? Submit a request
Please sign in to leave a comment.