Premium Outbound Antispam mail statistics are empty

Refers to:

  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux

Created:

2016-11-16 12:58:26 UTC

Modified:

2016-12-21 19:40:02 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Premium Outbound Antispam mail statistics are empty

Symptoms

Since the moment of installation, the Premium Outbound Antispam mail statistics are empty, i.e., 0 (zero) messages processed.

This issue is reproted as fixed since Plesk 11.0.9 MU#35

Cause

The issue is sometimes caused by the way PHP is configured on the server:

“safe_mode=on” 
Some functions are disabled in “php.ini” (disable_functions = dl, exec, passthru, pcntl_exec, posix_kill, posix_mkfifo, posix_setuid, proc_close, proc_open, proc_terminate, shell_exec, system, ftp_exec, leak, posix_setpgid, posix_setsid, proc_get_status, proc_nice, show_source).

The issue will be fixed in a future Plesk update.

Workaround

  1. Modify the ctoblogs.php script so that it uses the Parallels Plesk Panel PHP engine:

  2. Back up the script:

    # cp /opt/ctch/ctoblogs.php /opt/ctch/ctoblogs.php.orig
  3. Open it for editing and change this line:

    #!/usr/bin/php

    to

    #!/usr/local/psa/bin/sw-engine-pleskrun
  4. Remove previous stats:

    # rm -rf /var/log/ctchob/*

When statistics are calculated manually, the .part file gets overwritten and the lastepoch gets changed. That is why it is not recommended to run this script manually.

Have more questions? Submit a request
Please sign in to leave a comment.