[HOTFIX] Link 'Next Image >>' is missing before removed image even if next image exists

Created:

2016-11-16 12:58:16 UTC

Modified:

2017-04-24 12:01:41 UTC

0

Was this article helpful?


Have more questions?

Submit a request

[HOTFIX] Link 'Next Image >>' is missing before removed image even if next image exists

Applicable to:

  • Plesk Sitebuilder 4.5 for Linux

Symptoms

There is a site with " Image Galley " module published with Parallels Plesk Sitebuilder 4.5.

I've found that the " Next Image >> " and " << Previous Image " links do not work correctly. If you select a certain category and you start browsing through the images, for some of the images, even though they are not the last or first image from the category, the next button is missing, for others, both next and previous buttons are missing.

Cause

Such behavior is considered to be a software issue. The fix has been included to Parallels Plesk Sitebuilder since update 4.5.6.

Resolution

Install the latest update to Parallels Plesk Sitebuilder.

Hotfix for Parallels Plesk Sitebuilder version before 4.5.6

The hotfix is attached . To install the hotfix, download the archive and place it to root directory of Parallels Plesk Sitebuilder /usr/local/sitebuilder ( /opt/sitebuilder for Debian/Ubuntu). Then unpack it with " tar -zxf ":

~# mv ImageGallery.tgz /usr/local/sitebuilder
~# cd /usr/local/sitebuilder
~# tar -zxvf ImageGallery.tgz

After the hotfix is installed you should republish the entire content of sites that experience the problem.

Have more questions? Submit a request
Please sign in to leave a comment.