transaction support within the specified resource manager is not started or was shut down due to an error

Created:

2016-11-16 12:58:07 UTC

Modified:

2017-04-24 11:17:03 UTC

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transaction support within the specified resource manager is not started or was shut down due to an error

Applicable to:

  • Plesk 11.5 for Windows
  • Plesk 12.0 for Windows
  • Plesk 9.x and below for Windows

Symptoms

IIS service could not be started. The following error is being displayed in even log:

The World Wide Web Publishing Service service depends on the Windows Process Activation Service service which failed to start because of the following error:
Transaction support within the specified resource manager is not started or was shut down due to an error.

Cause

This issue occurs if the Windows file system transaction log is corrupted. The Windows file system uses the transaction log to recover system transactions when a file error occurs.

Resolution

  1. Clear all .dll files from 'C:\\windows\\system32\\config\\TxR'
  2. Run the following command in order to reset transaction log :

    fsutil resource setautoreset true c:\\
  3. Reboot the server.

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